Iphone user don't be left behind

If you have a firmware 1.0.2 or 1.1.1 then upgrade. At least go for 1.1.2 if you don't want to get 1.1.3. You will be too far behind if you keep waiting.

Just a few days back I updated my iphone to 1.1.3 from 1.0.2 because I was worried soon people will stop making way to upgrade from that firmware and I will be left behind. So at least go to 1.1.2 which seems quite stable and works with all the app's etc.

1.1.3 doesn't work well with the app's etc. Many app's are not yet compatible with 1.1.3,

Not only that there is already talk about 1.1.4 being released by the end of this month when apple releases SDK.

So upgrade or you will get left behind.